First version that works with Debian 9.. kind of